search
Categories
Sponsors
VirtualMetric Hyper-V Monitoring, Hyper-V Reporting
Archive
Blogroll

Badges
MCSE
Community

Cozumpark Bilisim Portali
Quick solution for SCVMM 2008 R2 bug of Hyper-V Linux IS 3.1
Posted in Virtual Machine Manager, Windows Powershell | 1 Comment | 2,997 views | 20/12/2011 21:41

If you have a public Hyper-V Cloud and use SCVMM, your customers can install Linux VM and install Hyper-V LIS v3.1 on it, there is nothing you can do to stop them. If they install it, you will not be able to use SCVMM due to LIS v3.1 bug.

System.ArgumentException: Version string portion was too short or too long.
at System.Version..ctor(String version)
at Microsoft.Carmine.ViridianImplementation.VirVMIntegrationService.PopulateKVPElements()

There are 2 options to prevent this.
1) You can provision all new virtual machines without Data Exchange offer.
2) You can disable Data Exchange offer only from Linux VMs to prevent that kind of problem.

If you have 0 – 50 VMs, it’s easy to deal with. But if you are a large Cloud provider, you can’t do it manually, you need scripting. So if you execute this command on SCVMM Powershell Interface, it’ll disable Data Exchange offer on all Linux VMs and save your SCVMM.

Get-VM * | where {$_.OperatingSystem -notlike "*Windows*"} | Set-VM -EnableDataExchange $false

As you see, it just looks for non-Windows machines and disable their Data Exchange offer. Good luck!


Comments (1)

Tim

December 21st, 2011
22:57:52

We are seeing this with Debian vm’s but this fix seems to break mysql: The service fails to start or stop ( if data exchange is disabled when vm is running ).



Leave a Reply